Starrett-3D Viewer Required Software
A set of optimized 3D renderers guarantees the best visual quality on both PCs with the latest video-cards and those with more basic video card capabilities.

Starrett-3D Viewer works as a VRML plug-in for popular Internet browsers (Internet Explorer, Netscape Browser, Mozilla, Firefox, etc.) and office applications (Microsoft PowerPoint, Microsoft Word, etc). At this time the Starrett-3D Viewer is available on the Windows platform.

But Starrett-3D is more than just a viewer! The powerful API allows for integration of Starrett-3D into any third-party application supporting ActiveX technology. With Starrett-3D, you can create a wide range of 3D applications – from visualization of scientific data to advanced 3D-enabled online services
View System Requirements

FREQUENTLY ASKED QUESTIONS

Please click on the red text below for answers to the most frequently asked questions about the Starrett-3D Viewer.

What are the system requirements to install and run the Starrett-3D Viewer?
Operating system:
  • Windows XP 32-bit, Service Pack 3
  • Windows 7 32-bit or 64-bit
Web browser:
  • Internet Explorer 8.0 or a later version
  • Mozilla Firefox 4.0 or a later version
  • Google Chrome 10 or a later version
  • Opera 11 or a later version
  • Safari 5 or a later version
Platform:
  • 1 GHz or faster processor
  • 1 GB RAM
  • DirectX 9.0c graphics device
  • 20 MB available hard disk space
Why can't I install the Starrett-3D viewer on my machine?
Most likely, you will need to disable your pop-up blocker in order to successfully install the Starrett-3D viewer.
Does the Starrett-3D Viewer work with Apple OS?
We are working on making Starrett-3D compatible with Apple operating systems, including the iPad.

In the meantime, Apple offers apps that enable viewing of flash and java web content that may allow Starrett-3D to run on your Apple product.

Click here to get Cloud Browser from the Apple iTunes Store.

There is also a paid app that works with the Starrett-3D viewer. The app is compatible with iPhone 3GS, iPhone 4, iPhone 4S, iPhone 5, iPod touch (3rd generation), iPod touch (4th generation), iPod touch (5th generation) and iPad. Requires iOS 5.0 or later. The app is optimized for iPhone 5.

Get the App
Why can't I find the 3D parts view for my tool?
The tools available through the Starrett-3D Viewer include the current models of our most popular tools. If you are looking for parts for an older model Starrett tool, please contact our Parts Department at (978) 249-3551.
Have another question not answered here?